Redmine repository not updating Sex dating in frankfort illinois

I just added a section in the plugin settings page to help debug path problems.Either install the latest repo code, or add the following code to app/views/settings/_redmine_git_erb: Git is installed to /usr/local/bin.Then you go in and fix the code so that the exact path is in /tmp/redmine_git_hosting. so when you edit it it doesn't fix the problem, but if you let the cache expire it starts working. $ git --help usage: git [--version] [--exec-path[=GIT_EXEC_PATH [--html-path] [-p|--paginate|--no-pager] [--no-replace-objects] [--bare] [--git-dir=GIT_DIR] [--work-tree=GIT_WORK_TREE] [-c name=value] [--help] COMMAND [ARGS] I'm still not convinced.Just because it's there when change to that user on the shell, doesn't mean it's accessible in rails/redmine.

||

I just added a section in the plugin settings page to help debug path problems.

Either install the latest repo code, or add the following code to app/views/settings/_redmine_git_erb: Git is installed to /usr/local/bin.

Then you go in and fix the code so that the exact path is in /tmp/redmine_git_hosting. so when you edit it it doesn't fix the problem, but if you let the cache expire it starts working. $ git --help usage: git [--version] [--exec-path[=GIT_EXEC_PATH]] [--html-path] [-p|--paginate|--no-pager] [--no-replace-objects] [--bare] [--git-dir=GIT_DIR] [--work-tree=GIT_WORK_TREE] [-c name=value] [--help] COMMAND [ARGS] I'm still not convinced.

]]

I tested with latest trunk, and 1.2.1, it's possible there's somewhere in between where there is still a problem (or, there was a still newer commit than when I last tested and it broke again). As far as the plugin configuration panel, everything looks good as far as I can tell ( What can I check for to see if the post-receive hook, or any hook, isn't functioning properly? (called from _run_rhtml_vendor47plugins47redmine_git_hosting47app47views47projects47settings47_repository46rhtml_locals_object_repository_tab at /home/vk/redmine-1.2/vendor/plugins/redmine_git_hosting/app/views/projects/settings/_repository.rhtml:56) DEPRECATION WARNING: @repository will no longer be implicitly assigned to repository.I had edited the PATH to include that directory on both the Redmine and Gitolite users before starting the testing I did on Saturday.I did not have to edit the /tmp/redmine_git_hosting/run_git_as_git_user file, unlike before.When refreshing the Repository page, it takes a noticeable amount of time. I may add an edit to this on Monday, I think there's a minor detail or two I might be leaving out.Anyhow, these were the major findings of the day, hope it helps.

Leave a Reply